Jump to content
OmarSanchez

Kontakt Help....

Recommended Posts

Hi All!

I'm trying to load an instrument on one of my tracks on logic pro 9.10, but it won't play on certain ones....is there some type of "channel" that I may need to change for it to play? It'll work on the first channel, but then the rest of the instruments are silent, unless I record using any kontakt sound library.....I'm having issues with those I've already recorded using my old sound library, and I'm trying to change it to Kontakt instruments.

Share this post


Link to post
Share on other sites

Huh, this is quite bizarre. Is there anyway you could document this? I'm just trying to visualize what could be causing the error. Note that I don't have Logic however.

Share this post


Link to post
Share on other sites

The kontakt instruments have a range settings in their information, that will be the range will play no matter what's the range in the note map, you may enlarge the the range of trombone from E to low Bb (using same sample) and it won't play that low Bb unless you edit the range in the instrument config.

 

 

EDIT:

Ah is called "Key range"

CreateResources.png

  • Like 1

Share this post


Link to post
Share on other sites

But it is within the preset range. Even if I change the note lower or higher. No sound comes out from pre made material unless it's the first track. I will try expanding the range the way you said and see if that help. :)

Share this post


Link to post
Share on other sites

does it sound if you manually press the key in kontakt keyboard ? (previously selecting the instrument you want)

Share this post


Link to post
Share on other sites

try to temporary set other vst, a non samples one, any synth vst, and see if it sounds, sequencer may not be even sending the note to the vst.

Share this post


Link to post
Share on other sites

It works with other non-kontakt libraries but with those they have an option to select the different channels (Aria, SampleTank, Morislov)

Share this post


Link to post
Share on other sites

kontakt is working as vst so the DAW must offer other options for it, look in the top of the kontakt window or little icons, you should configure the channels, maybe is receiving all in channel 1.

Share this post


Link to post
Share on other sites

Hopefully by now you've solved this problem but otherwise I'll try my best to offer some tech suggestions.  I use FL Studio so I don't know how good the carry over may be but I always figure new ideas are good so I'll give it a crack.  

 

You said it's only for old files, could it be that you accidentally recorded in different midi channels?  If I input a midi file from say Finale into FL Studio it often messes up the midi channel order.  Then I have to manually go into Kontakt and change the VST midi channel to whatever FL Studio assigned in the piano roll.  Then it will play correctly.  It will play correctly no matter what when I use players other than Kontakt so it must be something on Kontakt's end.

 

Regardless, I hope it is working now and my rather dubious suggestion is a moot point.  Otherwise I'll try to rack my brain for other ideas.  I think I've managed to break almost everything at least once while learning FL Studio.   :)

Share this post


Link to post
Share on other sites

If you generally use a single instance of Kontakt per instrument, you can go to Kontakt's settings and change the "MIDI channel assignment for loaded patches" to "omni". It's in the "handling" tab in Kontakt's settings. That way instruments won't get accidentally set to a different channel, leaving you troubleshooting why you aren't getting any audio out of Kontakt. ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...