Jump to content

Technical problems

Recommended Posts

Due to chopin accidentally breaking our server management software, a kind of "system restore" was required. This means that the board had to go back to a database backup from 3 days ago. When I checked the site today I realised this and restored a more recent backup which I happened to have made yesterday.

This means that some posts may be lost, maybe around 5-10. If you can't see your post, it wasn't deleted, it was because of this.

There is also an issue with the home page/wiki. I can't fix this because I don't know how the wiki works, but hopefully chopin will get to a computer and fix the problem.

Link to comment
Share on other sites

How did you manage to delete stuff by installing lilypond?!

It's a lovely piece of software. Better than Sibelius and Finale, in my opinion, for outputting music to paper. How will this system work? Submit a file to the server and it returns a graphics file?

Link to comment
Share on other sites

It has music code that you type into the wiki. Here is a short example:

{a b c}

and that will produce great looking music that you can save as a pdf. I messed up the system trying to upgrade glibc, I will never do that again! I am having so much trouble still trying to install the software because it has too many dependencies. I just joined a mailing list by lilypond, and hopefully they can help me out.

Link to comment
Share on other sites

What distro is it? Maybe I can help...

What you could try, possibly, is compile it on another machine with the libraries compiled in (static). This would make the binaries a little larger, but would be potentially easier to install. Maybe find a distro which includes lilypond and then recompile it in there so you know that the libraries are compiled in. I think you just add --static to the ./configure command. Emphasis on 'think'... I last compiled static binaries on the pre-bootstrap installation of Linux From Scratch, which must be about three years ago now.

Link to comment
Share on other sites

I am using an rpm. I basically have it installed by issuing this command:

rpm -i lilypond.rpm

It needs pango1.6 or greater, but it keeps saying I need glibc2.4. Pango1.6 or greater will not install. Here is the version of lilypond I am trying to install:

lilypond rpm The filename is called lilypond-2.6.4-1.i386.rpm

Here are the instructions:


And this is the problem I asked at a linux forum, but I didn't get much help:

I need a higher version of pango in order to install the stable version of lilypond 2.6.4-1. Pango will not install. This is how I installed it:

rpm -i --nodeps pango.rpm

cairo >= 0.9.2 is needed by pango-1.10.1-1

glib2 >= 2.4.0-1 is needed by pango-1.10.1-1

libc.so.6(GLIBC_2.4) is needed by pango-1.10.1-1

libcairo.so.2 is needed by pango-1.10.1-1

xorg-x11-libs is needed by pango-1.10.1-1

Despite overriding things, I still get the above message.

This is what the problem is, and I have no clue what to do. One person suggested this:

It looks like you have some reverse dependency problems. Go to the terminal and run "revdep-rebuild"

But I don't want to break the system again by doing something stupid!

Link to comment
Share on other sites

I assume you're using Fedora Core. Doesn't the package manager get the appropriate dependencies for you? If it's not installed, this site seems to have decent installation instructions. http://www.cpqlinux.com/apt.html

I think it's then just a case of telling it to 'apt-get package' and it does it, though it's a long time since I used red hat. Hope that helps. Lilypond may be apt-gettable, so try that first.

Link to comment
Share on other sites

I think I have Cent OS. I probably should just install a linux OS on my computer so I can experiment with it. I only use windows for my composition, so I can create a dual boot. Which version of linux is the best out there, or would you recommend?

Anyway, to the point. The older version of lilypond which is 2.2.6 installed and works, but the noteheads dont show. The newer version 2.6.4 won't install because glibc2.4 is needed. That apt-get package stuff confuses me. I am only aware of how to install through binaries (rpm's). Someone replied to my message about glibc 2.4. Here is the link:

Gentoo Forums

Read the last post (number 4) correctly. This guy said he installed a lilypond2.6.4.ebuild without any problems. I don't know how to work with these extensions, perhaps you can give me the light?

Oh, and the problem isn't with installing lilypond, lilypond is installed. Its dependencies are being a pain.

Link to comment
Share on other sites


How can v2.6.4 be installed if its dependencies are being a pain?

So... are you actually using Gentoo on the server? If not, then the post about the ebuild is of no use to you because the ebuild system is part of portage, the Gentoo package manager. RPMs are used in Red Hat systems (Red Hat Package Manager) and one or two other distributions have also adopted the RPM system. By posting on the Gentoo forums, the other members assume you are using Gentoo. If you state that you are not using Gentoo, then they probably won't (or can't) help you. If this is the case, then you should try http://www.justlinux.com/ which is a very good general Linux forum.

So, it is very important to know exactly what distribution of Linux you are trying to install Lilypond onto. If it is Gentoo, then let me know. It's therefore fairly easy to install Lilypond.

As far as having a distro to use on your own machine, you should take into consideration two things:

1) Do you mainly want to use it as a test bed for the server? In which case use the same distribution as is on the server. If you don't, you will find a few differences which may cause confusion or anoyance.

2) If you want Linux for mainly your own purposes, you could start off with something like Fedora Core, which is as far as I can remember easy to set up and get going with. I wouldn't consider something like Gentoo unless you like tweaking a lot in order to get things going (it's an OS that you set up almost from scratch). If you want something that's not so set up, you could try something like Debian or Slackware. http://www.linuxiso.org/ for install CD images.


Link to comment
Share on other sites

How can v2.6.4 be installed if its dependencies are being a pain?

I honestly don't know. I was able to install the program though issuing rpm -i lilypond.rpm

I am using a fedora core 4 binary, but it has an rpm extension. This is the exact filename:


Perhaps the problem is I am using a Fedora Core file instead of a Red Hat file? This was the only option to choose though from the site.

I will probably install Fedora Core 4 on my system for my own purposes, but also maybe some testing and so I can get used to a linux environment much easier. My only use for windows is my recording and notation! Although I do know windows pretty well, and how to troubleshoot it.

I think my best bet is to try to figure out why 2.2.6 is not showing the noteheads. I will ask around in the linux forum for help, thanks for the link.

Link to comment
Share on other sites


Fedora Core basically = Red Hat. A short while ago, Red Hat split into the server market and the other user market. We got Fedora Core while the server market got Red Hat. Therefore Fedora Core = Red Hat by another name.

Anyhow, the binary is for an i386, which means any intel-type processor with greater than 386 capabilities. The rpm means 'red hat package manager' which is merely a system for sorting and installing binaries. Perhaps one thing to check is if it's a PC you're installing onto or another platform. If it's a Sun machine, for example, you won't be able to run an i386 binary on it.

You can check this by looking at the output of the command:

cat /proc/cpuinfo

Link to comment
Share on other sites

I probably should delete this thread once the problem is solved!

Anyway, I think I am fine with the rpm's. My provider said that rpms can be installed without a problem.

Lets focus on 2.2.6 since it almost works. I will direct you to this link:

lilypond rpm 2.2.6

There is the list of dependencies it needs. I have trouble installing te_latex...I think that may be the problem why the noteheads aren't showing. However, latex is installed on my system, but it seems to be an older version. Do you have any idea how I can upgrade latex on my system?

I heard about the yum command. Like, yum upgrade latex, but I can never get that command to work. I even tried yum update glibc, but that didnt work either. Oh the frustrations.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...